Build(setup.py): Use python_requires keyword
[cookiecutter.git] / project_template / setup.py
1 #!/usr/bin/env python
2
3 from imp import load_source
4 from os.path import abspath, dirname, join
5
6 try:
7     from setuptools import setup
8     is_setuptools = True
9 except ImportError:
10     from distutils.core import setup
11     is_setuptools = False
12
13 kw = {}
14 if is_setuptools:
15     kw['python_requires'] = '>=2.7, !=3.0.*, !=3.1.*, !=3.2.*'
16
17 versionpath = join(abspath(dirname(__file__)), '{project}', '__version__.py')
18 load_source('{project}_version', versionpath)
19 # Ignore: E402 module level import not at top of file
20 from {project}_version import __version__  # noqa
21
22 setup(name='{project}',
23       version=__version__,
24       description='Broytman {project}',
25       long_description=open('README.rst', 'rU').read(),
26       author='Oleg Broytman',
27       author_email='phd@phdru.name',
28       url='http://phdru.name/Software/Python/{project}',
29       license='GPL',
30       keywords=[''],
31       platforms='Any',
32       classifiers=[
33           'Development Status :: 1 - Planning',
34           'Environment :: Console',
35           'Environment :: Web Environment',
36           'Intended Audience :: End Users/Desktop',
37           'License :: OSI Approved :: GNU General Public License (GPL)',
38           'Operating System :: OS Independent',
39           'Programming Language :: Python :: 2',
40           'Programming Language :: Python :: 2.7',
41           'Programming Language :: Python :: 3',
42           'Programming Language :: Python :: 3.3',
43           'Programming Language :: Python :: 3.4',
44           'Programming Language :: Python :: 3.5',
45           'Programming Language :: Python :: 3.6',
46       ],
47       packages=['{project}'],
48       package_data={'{project}': []},
49       scripts=[],
50       requires=[],
51       **kw
52       )