Use setuptools instead of distutils
[cookiecutter.git] / project_template / setup.py
1 #!/usr/bin/env python
2
3 from imp import load_source
4 from os.path import abspath, dirname, join
5 from setuptools import setup
6
7 versionpath = join(abspath(dirname(__file__)), '{project}', '__version__.py')
8 {project}_version = load_source('{project}_version', versionpath)
9
10 setup(name='{project}',
11       version={project}_version.__version__,
12       description='Broytman {project}',
13       long_description=open('README.rst', 'rU').read(),
14       author='Oleg Broytman',
15       author_email='phd@phdru.name',
16       url='http://phdru.name/Software/Python/{project}',
17       license='GPL',
18       keywords=[''],
19       platforms='Any',
20       classifiers=[
21           'Development Status :: 1 - Planning',
22           'Environment :: Console',
23           'Environment :: Web Environment',
24           'Intended Audience :: End Users/Desktop',
25           'License :: OSI Approved :: GNU General Public License (GPL)',
26           'Operating System :: OS Independent',
27           'Programming Language :: Python :: 2',
28           'Programming Language :: Python :: 2.7',
29           'Programming Language :: Python :: 3',
30           'Programming Language :: Python :: 3.3',
31           'Programming Language :: Python :: 3.4',
32           'Programming Language :: Python :: 3.5',
33           'Programming Language :: Python :: 3.6',
34       ],
35       packages=['{project}'],
36       package_data={'{project}': []},
37       scripts=[],
38       python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*',
39       requires=[],
40       )