]> git.phdru.name Git - cookiecutter.git/blobdiff - project_template/setup.py
Drop support for Python 3.3
[cookiecutter.git] / project_template / setup.py
index 52cb27e8c13c21feaf6f6397a56545c70acb3714..7e8df8d6259aaee864e2aa9ea72dbc0eb7502e9e 100755 (executable)
@@ -15,16 +15,16 @@ setup(
     long_description_content_type="text/x-rst",
     author='Oleg Broytman',
     author_email='phd@phdru.name',
-    url='http://phdru.name/Software/Python/{project}',
-    download_url='http://phdru.name/Software/Python/{project}',
+    url='https://phdru.name/Software/Python/{project}',
+    download_url='https://phdru.name/Software/Python/{project}',
     project_urls={
-        'Homepage': 'http://phdru.name/Software/Python/{project}',
+        'Homepage': 'https://phdru.name/Software/Python/{project}',
         'Documentation':
-            'http://phdru.name/Software/Python/{project}/docs/',
+            'https://phdru.name/Software/Python/{project}/docs/',
         'Russian docs':
-            'http://phdru.name/Software/Python/{project}/docs/ru/',
-        'Download': 'http://phdru.name/Software/Python/{project}',
-        'Git repo': 'http://git.phdru.name/{project}.git/',
+            'https://phdru.name/Software/Python/{project}/docs/ru/',
+        'Download': 'https://phdru.name/Software/Python/{project}',
+        'Git repo': 'https://git.phdru.name/{project}.git/',
         'Github repo': 'https://github.com/phdru/{project}',
         'Issue tracker': 'https://github.com/phdru/{project}/issues',
     },
@@ -41,7 +41,6 @@ setup(
         'Programming Language :: Python :: 2',
         'Programming Language :: Python :: 2.7',
         'Programming Language :: Python :: 3',
-        'Programming Language :: Python :: 3.3',
         'Programming Language :: Python :: 3.4',
         'Programming Language :: Python :: 3.5',
         'Programming Language :: Python :: 3.6',
@@ -49,6 +48,6 @@ setup(
     packages=['{project}'],
     package_data={'{project}': []},
     scripts=[],
-    python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*',
+    python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
     requires=[],
 )