]> git.phdru.name Git - cookiecutter.git/blobdiff - project_template/setup.py
Use setuptools instead of distutils
[cookiecutter.git] / project_template / setup.py
index a90dc05c5d825118b8fafc505a3b6a3a473b452a..816581f61249961f2e90809eef6f785356799873 100755 (executable)
@@ -2,29 +2,21 @@
 
 from imp import load_source
 from os.path import abspath, dirname, join
-
-try:
-    from setuptools import setup
-    is_setuptools = True
-except ImportError:
-    from distutils.core import setup
-    is_setuptools = False
+from setuptools import setup
 
 versionpath = join(abspath(dirname(__file__)), '{project}', '__version__.py')
-load_source('{project}_version', versionpath)
-# Ignore: E402 module level import not at top of file
-from {project}_version import __version__  # noqa
+{project}_version = load_source('{project}_version', versionpath)
 
 setup(name='{project}',
-      version=__version__,
+      version={project}_version.__version__,
       description='Broytman {project}',
-      long_description=open('README.txt', 'rtU').read(),
+      long_description=open('README.rst', 'rU').read(),
       author='Oleg Broytman',
       author_email='phd@phdru.name',
-      url='http://phdru.name/Software/Python/',
+      url='http://phdru.name/Software/Python/{project}',
       license='GPL',
-      platforms=['any'],
       keywords=[''],
+      platforms='Any',
       classifiers=[
           'Development Status :: 1 - Planning',
           'Environment :: Console',
@@ -33,12 +25,16 @@ setup(name='{project}',
           'License :: OSI Approved :: GNU General Public License (GPL)',
           'Operating System :: OS Independent',
           'Programming Language :: Python :: 2',
-          'Programming Language :: Python :: 2.6',
           'Programming Language :: Python :: 2.7',
-          'Programming Language :: Python :: 2 :: Only',
+          'Programming Language :: Python :: 3',
+          'Programming Language :: Python :: 3.3',
+          'Programming Language :: Python :: 3.4',
+          'Programming Language :: Python :: 3.5',
+          'Programming Language :: Python :: 3.6',
       ],
       packages=['{project}'],
       package_data={'{project}': []},
       scripts=[],
+      python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*',
       requires=[],
       )