Build(setup.py): Use `importlib` instead of deprecated `imp` for Python 3.4+
[cookiecutter.git] / project_template / setup.py
index 52cb27e8c13c21feaf6f6397a56545c70acb3714..8297efa6656c7c47a32c9c8d2f7051cf30a50c83 100755 (executable)
@@ -1,8 +1,24 @@
 #!/usr/bin/env python
 
-from imp import load_source
 from os.path import abspath, dirname, join
 from setuptools import setup
+import sys
+
+if sys.version_info[:2] == (2, 7):
+    from imp import load_source
+
+elif sys.version_info >= (3, 4):
+    from importlib.machinery import SourceFileLoader
+    import types
+
+    def load_source(fullname, path):
+        loader = SourceFileLoader(fullname, path)
+        loaded = types.ModuleType(loader.name)
+        loader.exec_module(loaded)
+        return loaded
+
+else:
+    raise ImportError("{project} requires Python 2.7 or 3.4+")
 
 versionpath = join(abspath(dirname(__file__)), '{project}', '__version__.py')
 {project}_version = load_source('{project}_version', versionpath)
@@ -15,16 +31,16 @@ setup(
     long_description_content_type="text/x-rst",
     author='Oleg Broytman',
     author_email='phd@phdru.name',
-    url='http://phdru.name/Software/Python/{project}',
-    download_url='http://phdru.name/Software/Python/{project}',
+    url='https://phdru.name/Software/Python/{project}',
+    download_url='https://phdru.name/Software/Python/{project}',
     project_urls={
-        'Homepage': 'http://phdru.name/Software/Python/{project}',
+        'Homepage': 'https://phdru.name/Software/Python/{project}',
         'Documentation':
-            'http://phdru.name/Software/Python/{project}/docs/',
+            'https://phdru.name/Software/Python/{project}/docs/',
         'Russian docs':
-            'http://phdru.name/Software/Python/{project}/docs/ru/',
-        'Download': 'http://phdru.name/Software/Python/{project}',
-        'Git repo': 'http://git.phdru.name/{project}.git/',
+            'https://phdru.name/Software/Python/{project}/docs/ru/',
+        'Download': 'https://phdru.name/Software/Python/{project}',
+        'Git repo': 'https://git.phdru.name/{project}.git/',
         'Github repo': 'https://github.com/phdru/{project}',
         'Issue tracker': 'https://github.com/phdru/{project}/issues',
     },
@@ -41,14 +57,14 @@ setup(
         'Programming Language :: Python :: 2',
         'Programming Language :: Python :: 2.7',
         'Programming Language :: Python :: 3',
-        'Programming Language :: Python :: 3.3',
         'Programming Language :: Python :: 3.4',
         'Programming Language :: Python :: 3.5',
         'Programming Language :: Python :: 3.6',
+        'Programming Language :: Python :: 3.7',
     ],
     packages=['{project}'],
     package_data={'{project}': []},
     scripts=[],
-    python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*',
+    python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
     requires=[],
 )