Use htdocs.path instead of absolute path
[cookiecutter.git] / project_template / setup.py
index 3b4e7b0fab8feaaace107a53a709119230f50f91..94c8d956c47bde66d0603ced1d20654cee090f65 100755 (executable)
@@ -3,11 +3,6 @@
 from imp import load_source
 from os.path import abspath, dirname, join
 
-try:
-    from ez_setup import use_setuptools
-    use_setuptools()
-except ImportError:
-    pass
 try:
     from setuptools import setup
     is_setuptools = True
@@ -15,18 +10,18 @@ except ImportError:
     from distutils.core import setup
     is_setuptools = False
 
-versionpath = join(abspath(dirname(__file__)), 'project', '__version__.py')
-load_source('project_version', versionpath)
+versionpath = join(abspath(dirname(__file__)), '{project}', '__version__.py')
+load_source('{project}_version', versionpath)
 # Ignore: E402 module level import not at top of file
-from project_version import __version__  # noqa
+from {project}_version import __version__  # noqa
 
-setup(name='Template project',
+setup(name='{project}',
       version=__version__,
-      description='Broytman Template Project',
+      description='Broytman {project}',
       long_description=open('README.txt', 'rtU').read(),
       author='Oleg Broytman',
       author_email='phd@phdru.name',
-      url='http://phdru.name/Software/Python/',
+      url='http://phdru.name/Software/Python/{project}',
       license='GPL',
       platforms=['any'],
       keywords=[''],
@@ -40,10 +35,14 @@ setup(name='Template project',
           'Programming Language :: Python :: 2',
           'Programming Language :: Python :: 2.6',
           'Programming Language :: Python :: 2.7',
-          'Programming Language :: Python :: 2 :: Only',
+          'Programming Language :: Python :: 3',
+          'Programming Language :: Python :: 3.3',
+          'Programming Language :: Python :: 3.4',
+          'Programming Language :: Python :: 3.5',
+          'Programming Language :: Python :: 3.6',
       ],
-      packages=['project'],
-      package_data={'project': []},
+      packages=['{project}'],
+      package_data={'{project}': []},
       scripts=[],
       requires=[],
       )