]> git.phdru.name Git - cookiecutter.git/blobdiff - project_template/setup.py
Feat: Allow to run clone2current/publish2web from the source repo
[cookiecutter.git] / project_template / setup.py
index f43df31f34be95223ae746c8186a10a6db820ff1..f988f7cbad61f7d527bea9e2c9be31f96cd65350 100755 (executable)
@@ -10,6 +10,10 @@ except ImportError:
     from distutils.core import setup
     is_setuptools = False
 
+kw = {}
+if is_setuptools:
+    kw['python_requires'] = '>=2.7, !=3.0.*, !=3.1.*, !=3.2.*'
+
 versionpath = join(abspath(dirname(__file__)), '{project}', '__version__.py')
 load_source('{project}_version', versionpath)
 # Ignore: E402 module level import not at top of file
@@ -23,8 +27,8 @@ setup(name='{project}',
       author_email='phd@phdru.name',
       url='http://phdru.name/Software/Python/{project}',
       license='GPL',
-      platforms=['any'],
       keywords=[''],
+      platforms='Any',
       classifiers=[
           'Development Status :: 1 - Planning',
           'Environment :: Console',
@@ -44,4 +48,5 @@ setup(name='{project}',
       package_data={'{project}': []},
       scripts=[],
       requires=[],
+      **kw
       )