Tests: Install psycopg2 from psycopg2-binary package
authorOleg Broytman <phd@phdru.name>
Wed, 6 Jun 2018 16:47:40 +0000 (19:47 +0300)
committerOleg Broytman <phd@phdru.name>
Wed, 6 Jun 2018 16:47:40 +0000 (19:47 +0300)
docs/news.rst
tox.ini

index dd51ecc..6cb2608 100644 (file)
@@ -7,6 +7,10 @@ Version 0.2.3 (2017-06-??)
 * Use remove-old-files.py from ppu to cleanup pip cache
   at Travis and AppVeyor.
 
+* Install psycopg2 from `psycopg2-binary`_ package.
+
+.. _`psycopg2-binary`: https://pypi.org/project/psycopg2-binary/
+
 Version 0.2.2 (2017-06-10)
 --------------------------
 
diff --git a/tox.ini b/tox.ini
index 6175f62..07930d6 100644 (file)
--- a/tox.ini
+++ b/tox.ini
@@ -14,7 +14,7 @@ commands =
     {envpython} -c "import struct; print(struct.calcsize('P') * 8)"
 deps =
     -rdevscripts/requirements/requirements_tests.txt
-    postgres: psycopg2
+    postgres: psycopg2-binary
 passenv = PGPASSWORD
 platform = linux
 # Don't fail or warn on uninstalled commands