Docs,tests: Limit Sphinx and pytest versions for Python 2.7 and 3.4
authorOleg Broytman <phd@phdru.name>
Mon, 25 Feb 2019 16:33:24 +0000 (19:33 +0300)
committerOleg Broytman <phd@phdru.name>
Mon, 25 Feb 2019 16:33:24 +0000 (19:33 +0300)
devscripts/requirements/requirements_docs.txt
devscripts/requirements/requirements_tests.txt

index 94d38eb..e36ba63 100644 (file)
@@ -1,3 +1,4 @@
 -r requirements.txt
 
-Sphinx
+Sphinx < 2.0; python_version == '2.7' or python_version == '3.4'
+Sphinx; python_version >= '3.5'
index 1214a91..973ffba 100644 (file)
@@ -1,5 +1,6 @@
 -r requirements.txt
 
-pytest < 5.0
+pytest < 5.0; python_version == '2.7' or python_version == '3.4'
+pytest; python_version >= '3.5'
 pytest-cov
 ppu