Drop support for Python 3.3
[cookiecutter.git] / project_template / setup.py
1 #!/usr/bin/env python
2
3 from imp import load_source
4 from os.path import abspath, dirname, join
5 from setuptools import setup
6
7 versionpath = join(abspath(dirname(__file__)), '{project}', '__version__.py')
8 {project}_version = load_source('{project}_version', versionpath)
9
10 setup(
11     name='{project}',
12     version={project}_version.__version__,
13     description='Broytman {project}',
14     long_description=open('README.rst', 'rU').read(),
15     long_description_content_type="text/x-rst",
16     author='Oleg Broytman',
17     author_email='phd@phdru.name',
18     url='https://phdru.name/Software/Python/{project}',
19     download_url='https://phdru.name/Software/Python/{project}',
20     project_urls={
21         'Homepage': 'https://phdru.name/Software/Python/{project}',
22         'Documentation':
23             'https://phdru.name/Software/Python/{project}/docs/',
24         'Russian docs':
25             'https://phdru.name/Software/Python/{project}/docs/ru/',
26         'Download': 'https://phdru.name/Software/Python/{project}',
27         'Git repo': 'https://git.phdru.name/{project}.git/',
28         'Github repo': 'https://github.com/phdru/{project}',
29         'Issue tracker': 'https://github.com/phdru/{project}/issues',
30     },
31     license='GPL',
32     keywords=[''],
33     platforms='Any',
34     classifiers=[
35         'Development Status :: 1 - Planning',
36         'Environment :: Console',
37         'Environment :: Web Environment',
38         'Intended Audience :: End Users/Desktop',
39         'License :: OSI Approved :: GNU General Public License (GPL)',
40         'Operating System :: OS Independent',
41         'Programming Language :: Python :: 2',
42         'Programming Language :: Python :: 2.7',
43         'Programming Language :: Python :: 3',
44         'Programming Language :: Python :: 3.4',
45         'Programming Language :: Python :: 3.5',
46         'Programming Language :: Python :: 3.6',
47     ],
48     packages=['{project}'],
49     package_data={'{project}': []},
50     scripts=[],
51     python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
52     requires=[],
53 )