Python: 2.6, 2.7 and 3.3+
[cookiecutter.git] / project_template / setup.py
1 #!/usr/bin/env python
2
3 from imp import load_source
4 from os.path import abspath, dirname, join
5
6 try:
7     from setuptools import setup
8     is_setuptools = True
9 except ImportError:
10     from distutils.core import setup
11     is_setuptools = False
12
13 versionpath = join(abspath(dirname(__file__)), '{project}', '__version__.py')
14 load_source('{project}_version', versionpath)
15 # Ignore: E402 module level import not at top of file
16 from {project}_version import __version__  # noqa
17
18 setup(name='{project}',
19       version=__version__,
20       description='Broytman {project}',
21       long_description=open('README.txt', 'rtU').read(),
22       author='Oleg Broytman',
23       author_email='phd@phdru.name',
24       url='http://phdru.name/Software/Python/',
25       license='GPL',
26       platforms=['any'],
27       keywords=[''],
28       classifiers=[
29           'Development Status :: 1 - Planning',
30           'Environment :: Console',
31           'Environment :: Web Environment',
32           'Intended Audience :: End Users/Desktop',
33           'License :: OSI Approved :: GNU General Public License (GPL)',
34           'Operating System :: OS Independent',
35           'Programming Language :: Python :: 2',
36           'Programming Language :: Python :: 2.6',
37           'Programming Language :: Python :: 2.7',
38           'Programming Language :: Python :: 3',
39           'Programming Language :: Python :: 3.3',
40           'Programming Language :: Python :: 3.4',
41           'Programming Language :: Python :: 3.5',
42           'Programming Language :: Python :: 3.6',
43       ],
44       packages=['{project}'],
45       package_data={'{project}': []},
46       scripts=[],
47       requires=[],
48       )