Tests(tox): Require tox <= 2.9.1
authorOleg Broytman <phd@phdru.name>
Wed, 4 Apr 2018 03:01:02 +0000 (06:01 +0300)
committerOleg Broytman <phd@phdru.name>
Wed, 4 Apr 2018 03:01:02 +0000 (06:01 +0300)
tox 3+ dropped support of Python 3.3.

project_template/.travis.yml
project_template/appveyor.yml
project_template/devscripts/requirements/requirements_tox.txt

index 6ca690c..74a6ebc 100644 (file)
@@ -39,7 +39,7 @@ matrix:
     - env: TOXENV=pypy
 
 install:
-  - travis_retry pip install --upgrade pip setuptools tox ppu
+  - travis_retry pip install --upgrade pip setuptools "tox <= 2.9.1" ppu
 
 script:
   - tox
index 0a2e20d..c0606b8 100644 (file)
@@ -72,7 +72,7 @@ install:
   - "python --version"
   - "python -c \"import struct; print(struct.calcsize('P') * 8)\""
   - "python -m pip install --upgrade pip setuptools"
-  - "pip install --upgrade tox ppu"
+  - "pip install --upgrade \"tox <= 2.9.1\" ppu"
   - "pip --version"
 
 # No build step - we don't have C extensions