CI(AppVeyor): Move `validators.py` -> `devscripts/CI/`
[sqlconvert.git] / setup.py
1 #!/usr/bin/env python
2
3 from os.path import abspath, dirname, join
4 from setuptools import setup
5 import sys
6
7 versionpath = join(abspath(dirname(__file__)), 'sqlconvert', '__version__.py')
8 sqlconvert_version = {}
9
10 if sys.version_info[:2] == (2, 7):
11     execfile(versionpath, sqlconvert_version)  # noqa: F821 'execfile' Py3
12
13 elif sys.version_info >= (3, 4):
14     exec(open(versionpath, 'rU').read(), sqlconvert_version)
15
16 else:
17     raise ImportError("sqlconvert requires Python 2.7 or 3.4+")
18
19 setup(
20     name='sqlconvert',
21     version=sqlconvert_version['__version__'],
22     description='Broytman sqlconvert',
23     long_description=open('README.rst', 'rU').read(),
24     long_description_content_type="text/x-rst",
25     author='Oleg Broytman',
26     author_email='phd@phdru.name',
27     url='https://phdru.name/Software/Python/sqlconvert/',
28     project_urls={
29         'Homepage': 'https://phdru.name/Software/Python/sqlconvert/',
30         'Documentation':
31             'https://phdru.name/Software/Python/sqlconvert/docs/',
32         'Download': 'https://pypi.org/project/sqlconvert/%s/'
33         % sqlconvert_version['__version__'],
34         'Git repo': 'https://git.phdru.name/sqlconvert.git/',
35         'Github repo': 'https://github.com/phdru/sqlconvert',
36         'Issue tracker': 'https://github.com/phdru/sqlconvert/issues',
37     },
38     license='GPL',
39     keywords=['sql', 'mysql', 'postgresql', 'sqlite', 'insert'],
40     platforms='Any',
41     classifiers=[
42         'Development Status :: 3 - Alpha',
43         'Environment :: Console',
44         'Intended Audience :: Developers',
45         'License :: OSI Approved :: GNU General Public License (GPL)',
46         'Operating System :: OS Independent',
47         'Programming Language :: Python :: 2',
48         'Programming Language :: Python :: 2.7',
49         'Programming Language :: Python :: 3',
50         'Programming Language :: Python :: 3.4',
51         'Programming Language :: Python :: 3.5',
52         'Programming Language :: Python :: 3.6',
53         'Programming Language :: Python :: 3.7',
54     ],
55     packages=['sqlconvert'],
56     scripts=['scripts/mysql2sql'],
57     python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
58     install_requires=[
59         'SQLObject>=2.2.1; python_version=="2.7"',
60         'SQLObject>=3.0.0; python_version>="3.4"',
61         'm_lib.defenc>=1.0',
62         'm_lib>=3.1',
63         'sqlparse',
64     ],
65 )