Tests: Require tox < 3.1 to avoid basepython conflicts